Programa ingeniería de sistemas

Informática. Taller de profundización. Algoritmos

  • Enviado por: El remitente no desea revelar su nombre
  • Idioma: castellano
  • País: Colombia Colombia
  • 4 páginas
publicidad

Escuela de Ciencias Básicas Tecnología e Ingeniería ECBTI

Programa Ingeniería de sistemas

Taller de profundización

Algoritmos

1.Diligencie la siguiente tabla teniendo en cuenta los ejercicios de la primera columna

Proceso ejercicio1

Escribir "Digite un número";

Leer x;

z<-x/2;

Escribir z;

FinProceso

Objetivo

Entradas

Proceso

Salida

Prueba de escritorio

Variables

Prueba 1

Prueba 2

Proceso ejercicio2

Escribir "Digite un número";

Leer x;

z<-x*x;

Escribir z;

FinProceso

Proceso ejercicio3

Escribir "Digite un número";

Leer x;

porc<-10;

z<-x*(porc/100);

Escribir z;

FinProceso

Proceso ejercicio4

Escribir "Digite nota 1";

Leer n1;

Escribir "Digite nota 2";

Leer n2;

final<-(n1*0.6)+(n2*0.4)

Escribir final;

FinProceso

Proceso ejercicio5

Escribir "Digite nota";

Leer nota;

Si nota>=3 Entonces

Escribir "Aprobado";

Sino

Escribir "Reprobado";

FinSi

FinProceso

  • Transcriba los anteriores ejercicios en el programa PseInt y pruébelos.

  • Realice los algoritmos, según los objetivos propuestos

  • Proceso ejercicio6

    FinProceso

    Objetivo

    Cálculo del valor de una venta incrementando el valor del IVA

    Entradas

    Proceso

    Salida

    Prueba de escritorio

    Proceso ejercicio7

    FinProceso

    Cálculo del valor a pagar por una compra a partir del valor unitario.

    Proceso ejercicio8

    FinProceso

    Cálculo de comisión sobre ventas.

    Proceso ejercicio9

    FinProceso

    Cálculo de la edad de una persona en meses.

    Proceso ejercicio10

    FinProceso

    Convertir grados centígrados a Fahrenheit

    Ejercicio 11

    La jornada laboral de una persona contempla que debe trabajar de lunes a viernes y sábado medio día.

    Elaborar un algoritmo que permita calcular la cantidad de días que descansa en determinado número de meses.

    Ejercicio 12

    Una persona estima que el dinero que gasta mensualmente en trasporte equivale a la tercera parte del valor que invierte en alimentación.

    Determinar a través de un algoritmo, el valor mensual de transporte

    Ejercicio 13

    Un empleador debe considerar que al contratar una persona es necesario reservar adicionalmente al valor del salario, dinero por los siguientes conceptos correspondientes a prestaciones sociales.

    • Prima de servicios -> 1 salario al año

    • Cesantías -> 1 salario al año

    • Intereses sobre cesantías -> 12% sobre el valor de Cesantías

    • Vacaciones -> medio salario al año

    Diseñe un algoritmo para el cálculo del valor de prestaciones sociales mensualmente.

    Ejercicio 14

    Elaborar un algoritmo que permita establecer si un número es par o impar.

    Para el desarrollo de este ejercicio es importante tener en cuenta el residuo de la división entre dos números.

    Ejemplo

    9

    2

    1

    4

    El residuo de la división de 9 entre 2 es 1-> para hacer referencia al residuo se utiliza el operador, entonces:

    9 mod 2 = 1 mientras que

    La división hace referencia a la parte entera de la división

    9 / 2 = 4

    Ejercicio 15

    Para calcular el índice de masa corporal (IMC) debemos dividir nuestro peso en kilogramos por el resultado de nuestra altura (en metros, no en centímetros) al cuadrado. O, dicho al revés, debemos elevar nuestra altura al cuadrado, y luego dividir nuestro peso (en kilogramos) por el resultado que nos había dado antes. Entonces, la fórmula para calcular nuestro IMC queda así: IMC= peso (kg) / [estatura (m)]2

    Para determinar si el cociente que resulta está o no dentro de un peso saludable, sencillo: Si da entre 20 y 25 significa que se tiene un peso acorde, si es inferior, hay problemas de bajo peso y si, opuestamente, el IMC da un resultado superior a 25, la persona estaría con sobrepeso. Asimismo, si este cociente se mantiene entre 25 y 30, efectivamente, nos indica un sobrepeso, pero si supera los 30 puntos, nos estaría indicando ya obesidad.

    Mediante un algoritmo, calcular el IMC.