Resolucion de problemas y algoritmos

Software. Ejercicios. Lenguajes de programación. Pascal. Visual Basic. Datos. Variables. Valores. Declaración

  • Enviado por: Nory
  • Idioma: castellano
  • País: Argentina Argentina
  • 5 páginas
publicidad

Ejercicio Nº1

Se leen tres datos que representan el nombre, sueldo básico y antigüedad de un empleado y

se debe escribir el nombre y el sueldo a cobrar. El sueldo se calcula, adicionando al básico el 15 % del mismo, si la antigüedad supera los 3 años; 30 % del mismo, si la antigüedad supera los 6 años y 50 % del mismo, si la antigüedad supera los 10 años.

Resolución:

Variable Descripción

NOMBRE Nombre del empleado

SB Sueldo básico

ANT Antigüedad

PORCENTAJE Porcentaje de antigüedad

SUELDO Sueldo a cobrar

LEER NOMBRE

LEER SB

LEER ANT

PORCENTAJE 1

SI ANT>3 Y ANT <6

ENTONCES

PORCENTAJE 1.15

SINO

SI ANT>6 Y (ANT<10 O ANT=10)

ENTONCES

PORCENTAJE 1.3

SINO

SI ANT>10

ENTONCES

PORCENTAJE 1.5

FINSI

FINSI

FINSI

SUELDO SB * PORCENTAJE

ESCRIBIR NOMBRE

ESCRIBIR SUELDO

Ejercicio Nº2

Escribir un algoritmo que determine en la variable MINIMO el menor de los valores de cuatro variables numéricas.

C 1

LEER MIN

MIENTRAS C<4 HACER

LEER B

SI MIN>B

ENTONCES

MIN B

FINSI

C C+1

FINMIENTRAS

ESCRIBIR MIN

Ejercicio Nº3

Se leen tres valores que corresponden al día, mes y año. Verificar si los datos constituyen una fecha posible o no.

LEER DIA

LEER MES

LEER AÑO

FECHA “No valida”

SI (DIA <31) Y (MES<13)

ENTONCES

FECHA “Valida”

SINO

SI (DIA = 31) Y (MES=1) O (MES=3) O (MES=5) 0 (MES=7) 0 (MES=8) 0 (MES=10) 0 (MES=12)

ENTONCES

FECHA Valida

FINSI

SI (DIA=29) Y (MES=2)

ENTONCES

R AÑO MOD 4

SI R = 0

ENTONCES

FECHA “Valida”

FINSI

SINO

SI (DIA<29) Y (MES=2)

ENTOCES

FECHA “VALIDA”

FINSI

FINSI

FINSI

ESCRIBIR “LA FECHA ES” FECHA

Ejercicio Nº4

Ordenar tres valores numéricos, de menor a mayor.

LEER A

LEER B

LEER C

SI A<B Y A<C

ENTONCES

MENOR A

SI B<C

ENTONCES

MEDIO B

MAYOR C

SINO

MEDIO C

MAYOR B

FINSI

FINSI

SI B<A Y B<C

ENTONCES

MENOR B

SI A<C

ENTONCES

MEDIO A

MAYORC

SINO

MEDIO C

MAYOR A

FINSI

FINSI

SI C<A Y C<B

ENTONCES

MENORC

SI A<B

ENTONCES

MEDIO A

MAYOR B

SINO

MEDIO B

MAYOR A

FINSI

FINSI

ESCRIBIR MENOR

ESCRIBIR MEDIO

ESCRIBIR MAYOR

Ejercicio Nº5

Se leen 300 datos que representan el peso de niños internados en un hospital. Se pide confeccionar la siguiente tabla:

Entre 0 y 10 Kg. Hay............niños

Entre 10 y 20 Kg. Hay..........niños

Entre 20 y 30 Kg. hay...........niños

de más de 30 Kg. hay...........niños

Variable Descripción

PS1 Entre 0 y 10 Kg

PS2 Entre 10 y 20Kg.

PS3 Entre 20 y 30Kg.

PS4 Más de 30Kg.

PS1 0

PS2 0

PS3 0

PS4 0

PARA N DESDE 1 HASTA 300 CON PASO 1 HACER

LEER PESO

SI PESO <10 O PESO = 10

ENTONCES

PS1 PS1+1

FINSI

SI PESO >10 Y (PESO<20 O PESO = 20)

ENTONCES

PS2 PS2+1

FINSI

SI PESO>20 Y (PESO<30 O PESO = 30)

ENTONCES

PS3 PS3+1

FINSI

SI PESO>30

ENTONCES

PS4 PS4+1

FINSI

FINPARA

ESCRIBIR “Entre 0 y 10Kg. hay” PS1 “niños”

ESCRIBIR “Entre10 y 20Kg. hay” PS2 “niños”

ESCRIBIR “Entre 20 y 30Kg. hay” PS3 “niños”

ESCRIBIR”De más de 30kg. hay” PS4 “niños”

Ejercicio Nº6

Se tienen las calificaciones individuales de los alumnos que cursaron una materia en tres aspectos: nota del trabajo realizado en el laboratorio de computación, nota promedio de los exámenes parciales y nota del examen final. Por cada alumno, se lee su nombre y las tres calificaciones mencionadas, y se quiere obtener un listado donde, cada línea, debe contener el nombre de un alumno y su correspondiente nota promedio.

ALUMNO “ “

MIENTRAS ALUMNO<>”FIN” HACER

LEER ALUMNO

LEER TP

LEER EP

LEER FINAL

PROMEDIO(TP+EP+FINAL)/3

ESCRIBIR ALUMNO

ESCRIBIR PROMEDIO

FINMIENTRAS

Ejercicio Nº7

Una empresa fabrica dos productos A y B y desea saber cuál de ellos es el más aceptado en el mercado. Para ello realiza una encuesta y, por cada persona interrogada, se obtiene un par de valores: el primer valor del par indica la aceptación o no del producto A según sea 1 o 0; el segundo valor del par corresponde al producto B. Por ejemplo, el par (1,0) significa que el encuestado acepta el producto A pero no el B. Se pide:

Total de encuestados.

Porcentaje de consumidores que aceptan:

el producto A.

el producto B

los dos productos.

el producto A pero no el B.

el producto B pero no el A.

ninguno de los dos productos.

Variable Descripción

PA Cantidad de consumidores que aceptan el producto A

PB Cantidad de consumidores que aceptan el producto B

A Primer valor del par ingresado

B Segundo valor del par ingresado

ANB Cantidad que acepta A y no B

BNA Cantidad que acepta B y no A

AB Cantidad que aceptan A y B

NAB Cantidad que no aceptan ni A ni B

PORCENTA Porcentaje de consumidores que aceptan A

PORCENTB Porcentaje de consumidores que aceptan B

PROCENTANB Porcentaje de ANB

PROCENTBNA Porcentaje de BNA

PORCENTNAB Porcentaje de NAB

PORCENTAB Porcentaje de AB

PA0, PB, ANB0, BNA0, AB0, NAB0, C0

MIENTRAS A>1 HACER

LEER A, B

CC +1

SI A=0 Y B=1

ENTONCES

PBPB+1

BNABNA+1

FINSI

SI A=1 Y B=0

ENTONCES

PAPA+1

ANBANB+1

FINSI

SI A=1 Y B=1

ENTONCES

PAPA+1

PBPB+1

AB1

FINSI

SI A=0 Y B=0

ENTONCES

NABNAB+1

FINSI

FINMIENTRAS

CC-1

PORCENTA 100*PA/C

PORCENTB 100*PB/C

PORCENTAB 100*AB/C

PORCENTANB 100*ANB/C

PORCENTBNA 100*BNA/C

PORCENTNAB 100*NAB/C

ESCRIBIR ”Consumidores del Producto A” PORCENTA “%”

ESCRIBIR ”Consumidores del Producto B” PORCENTB “%”

ESCRIBIR ”Consumidores del ambos productos” PORCENTAB “%”

ESCRIBIR ”Consumidores del Producto A pero no del B” PORCENTANB “%”

ESCRIBIR ”Consumidores del Producto B pero no del A” PORCENTBNA “%”

ESCRIBIR “Ninguno de los dos productos” PORCENTNAB “%”

EjercicioNº8

Suponiendo que el precio de cualquier artículo que se vende en un negocio es inferior o igual a $ 1 y que se abona con un billete de $ 2, diseñar un algoritmo para leer el precio de los artículos vendidos y calcular el número de cada clase de moneda que debe darse a cambio, de tal manera que se devuelva un mínimo de monedas fraccionarias.

Variable Descripción

M1 Moneda de $1

M50 Moneda de $0.50

M25 Moneda de $0.25

M10 Monedas de $0.10

M05 Moneda de $0.05

LEER PRECIO

VUELTO=1< PRECIO

M1=1

Si(vuelto >0,50)o(vuelto=0,50)

Entonces

Vuelto=<0,50

M50=1

Finsi

Si (vuelto >25)o(vuelto=0,25)

Entonces

Vuelto=vuelto=0,25

M25=1

Finsi

Mientras

(vuelto>0,10) y (vuelto=0,10)

vuelto=vuelto - 0,10

m10=m10+10

fin mientras

si (vuelto>0,05)y (vuelto=0,05)

entonces

vuelto=vuelto=0,05

m05=1

finsi

Resolución de Problemas y Algoritmos

5