Programación: presentación de un algoritmo

Informática. Procedimiento. Presentación. Artículos. Captura

  • Enviado por: Pollo
  • Idioma: castellano
  • País: Colombia Colombia
  • 10 páginas
publicidad

PROCEDIMIENTO Presentación

  • Inicio

  • Imprimir “Programa de inventarios”

  • Imprimir “Por Juan Camilo Valencia Ramírez”

  • Imprimir “Universidad Nacional de Manizales”

  • Imprimir “Asignatura: Informática y lógica”

  • Imprimir “Profesor Alonso Tamayo Alzate”

  • Fin

  • PROCEDIMIENTO Número_Artículos(Nart)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de artículos a adicionar”

    Leer Nart

    Si Nart < 0

    Entonces imprimir “Error de Datos, ingrese de nuevo”

    Fin_si

    Hasta que Nart > 0

  • Fin

  • PROCEDIMIENTO Captura_Artículos(Cod, Nom, Nex)

  • Inicio

  • Para j de 1 hasta Noart hacer

  • Repetir

    Imprimir “Ingrese el código del artículo”

    Leer Cod(j)

    Si Cod(j) < 0

    Entonces imprimir “Error de datos, ingrese de

    nuevo”

    Fin_si

    Hasta que Cod(j) Z > 0

    Imprimir “Ingrese el nombre del artículo”

    Leer Nom(j)

    Repetir

    Imprimir “Ingrese el número de unidades del artículo”

    Leer Nex(j)

    Si Nex(j) < 0

    Entonces imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Nex(j) > 0

    Fin_para

  • Fin

  • PROCEDIMIENTO SalidasA(Cod, Nom, Nex)

  • Inicio

  • Para j de 1 hasta Noart hacer

  • Imprimir “ El código del artículo es” Cod(j)

    Imprimir “ El nombre del artículo es” Nom(j)

    Imprimir “ El número de unidades del artículo es” Nex(j)

    Fin_para

  • Fin

  • PROCEDIMIENTO Adicionar_artículos(Nte, Noart, Nart, Cod, Nom,

    Nex)

  • Inicio

  • Llamar Número_Artículos(Nart)

  • Noart!Noart+Nart

  • Imprimir “El número de artículos a adicionar es” Nart

  • Para j de 1 hasta Nart hacer

  • Llamar Captura_Artículos(Cod, Nom, Nex)

    Llamar SalidasA(Cod, Nom, Nex)

    Nte!Nte+Nex(j)

    Fin_para

    6. Imprimir “El número total de existencias entre todos los

    artículos es” Nte

    7. Imprimir “El número total de artículos es” Noart

  • Fin

  • PROCEDIMIENTO CapturaU(Nartu)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de artículos a los que

    adicionará unidades”

    Leer Nartu

    Si Nartu < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Nartu > 0

  • Fin

  • PROCEDIMIENTO Capturad(Uad)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de unidades que va a

    adicionar para ese artículo”

    Leer Uad

    Si Uad < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Uad > 0

  • Fin

  • PROCEDIMIENTO Captura_Artículo_Modificar(Coda)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el código del artículo que va a

    modificar”

    Leer Coda

    Si Coda < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Coda > 0

  • Fin

  • PROCEDIMIENTO Adicionar_Unidades(Nartu, Coda, Uad, Cod,

    Nex)

  • Inicio

  • Llamar CapturaU(Nartu)

  • Para i de 1 hasta Nartu hacer

  • Llamar Captura_Artículos_Modificar(Coda)

    Llamar CapturaU(Uad)

    Para j de 1 hasta Noart hacer

    Leer Cod(j)

    Si Cod(j) = Coda

    Entonces Nex(j)!Nex(j)+Uad

    Fin_si

    Fin_para

    Fin_para

  • Fin

  • PROCEDIMIENTO Consultar_Inventario(Cod, Nom, Nex, Noart,

    Nte)

  • Inicio

  • Para j de 1 hasta Noart hacer

  • Llamar SalidasA(Cod, Nom, Nex)

    Fin_para

  • Imprimir “El número total de artículos es” Noart

  • Imprimir “El número total de unidades es” Nte

  • Fin

  • PROCEDIMIENTO Captura_Número_artículos_vendidos(Noarven)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de artículos vendidos”

    Leer Noarven

    Si Noarven < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Noarven > 0

  • Fin

  • PROCEDIMIENTO Captura_Número_Unidades_Vendidas(Uvenar)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de unidades vendidas del

    artículo”

    Leer Uvenar

    Si Uvenar < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Uvenar > 0

  • Fin

  • PROCEDIMIENTO Venta_artículos_Unidades(Noarven, Coda,

    Uvenar, Noart, Cod, Nex)

  • Inicio

  • Llamar Captura_Número_artículos_vendidos(Noarven)

  • Para i de 1 hasta Noarven hacer

  • Llamar Captura_Artículos_Modificar(Coda)

    Llamar Captura_Número_Unidades_Vendidas(Uvenar)

    Para j de 1 hasta Noart hacer

    Leer Cod(j)

    Si Cod(j) = Coda

    Entonces Nex(J)!Nex(j) - Uvenar

    Fin_si

    Fin_para

    Fin_para

  • Fin

  • PROCEDIMIENTO Captura(Min, Max)

  • Inicio

  • Para j de 1 hasta Noart hacer

  • Repetir

    Imprimir “Ingrese el código del artículo”

    Leer CodMM(j)

    Si CodMM(j) < 0

    Entonces Imprimir“Error de datos ingrese de nuevo”

    Fin_si

    Hasta que CodMM(j) > 0

    Repetir

    Imprimir “Ingrese el mínimo de unidades del artículo”

    Leer Min(j)

    Si Min(j) < 0

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Min(j) > 0

    Repetir

    Imprimir “Ingrese el máximo de unidades del artículo”

    Leer Max(j)

    Si Max(j) < Min(j)

    Entonces Imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Max(j) > Min(j)

    Imprimir “El mínimo de unidades del artículo es” Min(j)

    Imprimir “El máximo de unidades del artículo es” Max(j)

    Fin_para

  • Fin

  • PROCEDIMIENTO Unidades_Requeridas(Min, Max, Noart, Nex,

    Cod, Nom, Unre)

  • Inicio

  • Llamar Captura_Mínimo_Máximo(Min, Max)

  • Para j de 1 hasta Noart hacer

  • Leer Nex(j) , Cod(j), Nom(j)

    Si Nex(j) < Min(j)

    Entonces Unre(j)!Max(j) - Nex(j)

    Fin_si

    Imprimir “Las unidades requeridas para el artículo” Cod(j),

    Nom(j)

    Imprimir “Son” Unre(j)

    Fin_para

  • Fin

  • PROCEDIMIENTO CapturaB(Nb)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de artículos que desea borrar”

    Leer Nb

    Si Nb < 0

    Entonces imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Nb > 0

  • Fin

  • PROCEDIMIENTO ArtículosB(CodB)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el código del artículo que va a borrar”

    Leer CodB

    Si CodB < 0

    Entonces imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que CodB > 0

  • Fin

  • PROCEDIMIENTO Borrar_Artículos(Nb, CodB, Noart, Cod, Nom,

    Nex, Nte)

  • Inicio

  • Llamar CapturaB(Nb)

  • Para i de 1 hasta Nb hacer

  • Llamar ArtículosB(CodB)

    Para j de 1 hasta Noart hacer

    Leer Cod(j)

    Si Cod(j) = CodB

    Entonces k!j

    Para j de (k + 1) hasta Noart hacer

    Leer Cod(j), Nom(j), Nex(j)

    Cod( j-1)!Cod(j)

    Nom(j -1)!Nom(j)

    Nex(j -1)!Nex(j)

    Fin_para

    Noart!Noart - 1

    Nte!Nte - Nex(j)

    Fin_si

    Fin_para

    Fin_para

  • Fin

  • PROCEDIMIENTO CapturaNam(Nacn)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el número de artículos a los que

    cambiará el nombre”

    Leer Nacn

    Si Nacn < 0

    Entonces imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Nacn > 0

  • Fin

  • PROCEDIMIENTO CapturaCodc(Codacn)

  • Inicio

  • Repetir

  • Imprimir “Ingrese el código del artículo al que cambiará el

    nombre”

    Leer Codacn

    Si Codacn < 0

    Entonces imprimir “Error de datos, ingrese de nuevo”

    Fin_si

    Hasta que Codacn > 0

  • Fin

  • PROCEDIMIENTO Cambiar_Nombre_Artículo(Nacn, Codacn, Cod,

    Nomn, Nom)

  • inicio

  • Llamar CapturaNam(Nacn)

  • Para i de 1 hasta Nacn hacer

  • Llamar CapturaCodc(Codacn)

    Para j de 1 hasta Noart hacer

    Leer Cod(j)

    Si Cod(j) = Codacn

    Entonces imprimir “Ingrese el nuevo nombre del

    artículo”

    Leer Nomn

    Nom(j)!Nomn

    Fin_si

    Fin_para

    Fin_para

  • Fin

  • PROCEDIMIENTO Fin_Sesión

  • Inicio

  • Imprimir “La sesión ha terminado”

  • Fin

  • PROCEDIMIENTO Menú(opción)

  • Inicio

  • Imprimir “Menú de inventarios”

  • Imprimir “1: Adicionar artículos”

  • Imprimir “2: Adicionar unidades”

  • Imprimir “3: Consultar inventario”

  • Imprimir “4: Venta de artículos”

  • Imprimir “5: Unidades requeridas”

  • Imprimir “6: Borrar artículos”

  • Imprimir “7: Cambiar nombre de artículo”

  • Imprimir “8: Terminar sesión”

  • Repetir

  • Imprimir “teclee la opción escogida”

    Leer opción

    Si (opción < 1) o (opción >8)

    Entonces imprimir “Error al escoger opción”

    Fin_si

    Hasta que (opción >= 1) y (opción <= 8)

  • Fin

  • PROGRAMA Principal

  • Inicio

  • Noart!0

  • Nte!0

  • Llamar Presentación

  • Llamar Menú(opción)

  • Mientras opción <>8 hacer

  • En caso de opción hacer

    1: Llamar Adicionar_Artículos(Nte, Noart, Nart, Cod, Nom,

    Nex)

    2: Llamar Adicionar_Unidades(Nartu, Coda, Uad, Cod,

    Nex)

    3: Llamar Consultar_Inventario(Cod, Nom, Nex,

    Noart, Nte)

    4: Llamar Venta_Artículos_Unidades(Noarven, Coda,

    Uvenar, Noart, Cod, Nex)

    5: Llamar Unidades_Requeridas(Min, Max, Nex, Cod,

    Nom,Unre

    6: Llamar Borrar_Artículos(Nb, CodB, Noart, Cod, Nom,

    Nex, Nte)

    7: Llamar Cambiar_Nombre_Artículo(Nac, Codacn, Cod,

    Nomn, Nom)

    Fin_caso

    Fin_mientras

  • Llamar Fin_Sesión

  • Fin