Funciones

Programas informáticos. Excel. Sintaxis. Promedio. Máxima. Mínima. Moda. Mediana

  • Enviado por: Jokshua
  • Idioma: castellano
  • País: Perú Perú
  • 7 páginas

publicidad
cursos destacados
Conviértete en un Desarrollador Web Desde Cero aprendiendo PHP y MySQL (Capítulo 3)
Conviértete en un Desarrollador Web Desde Cero aprendiendo PHP y MySQL (Capítulo 3)
¡Bienvenidos a la versión española del curso más completo y más vendido en la web...
Ver más información

Instalación de WordPress
Instalación de WordPress
En el siguiente curso aprenderemos a subir los archivos de Wordpress a nuestro hosting contratado, dar de alta una Base...
Ver más información


Introducción a las funciones

Definición Una función es una fórmula ya preparada por Excel, que permite ahorrar tiempo y cálculos, y que produce un resultado. Por ejemplo, imaginemos que tenemos que sumar una columna de datos numéricos:

'Funciones'

En el ejemplo de la izquierda podríamos colocar en la celda A10 la fórmula: =A3+A4+A5+A6+A7+A8, pero esto mismo resultaría horrible si en lugar de 5 celdas hubiese que sumar 100.

En lugar de esa fórmula, utilizamos la función =SUMA(A3:A8) que realizará exactamente la misma operación; sumar el rango de celdas A3:A8.

Las funciones aceptan unos valores (en este caso el rango de celdas) llamados argumentos.
 
   Sintaxis Observa la sintaxis de una función:

'Funciones'

Las funciones las podemos introducir de dos formas:

Mediante teclado.

Mediante el asistente para funciones.

La función =SI( )

Definición y sintaxis La función =SI( ) es una de las más potentes que tiene Excel. Esta función comprueba si se cumple una condición. Si ésta se cumple, da como resultado VERDADERO. Si la condición no se cumple, da como resultado FALSO. Obseva la sintaxis:

=SI(Condición;Verdadero;Falso)

Esta es la forma más simple de representar esta función, porque la misma se puede complicar que no veas. De momento vamos a proponer un ejemplo: 

Observa la hoja de la derecha. Se trata del último ejemplo de la lección anterior. Observa que hemos añadido nuevas celdas y hemos modificado algunas. Ahora se trata de colocar una función =SI( ) en la celda E15 (celda rosa del descuento). 'Funciones'

Ejemplo Vamos a hacer que la factura del ejemplo anterior nos haga un descuento del 10% sólo en el caso de cobrar al contado. La fórmula se colocará en la celda E15 y será la siguiente:

=SI(A17="Contado";E14*10%;0;)

Esta fórmula mirará si en la casilla A17 (celda amarilla) existe la palabra Contado. En  tal caso, ejecutará una fórmula (10% de descuento), en caso contrario, colocará simplemente un cero en la celda E15, es decir, no realizará ningún cálculo. Observa el resultado:

'Funciones'

En el siguiente ejemplo vamos a ver una variación de la función =SI

    En el ejemplo anterior vimos que la función =SI debía cumplir una condición, que era la de controlar si en una celda determinada había un texto. Pero, ¿qué pasaría si se

'Funciones'

Tuviesen que cumplir más de una condición? Supongamos que la función =SI debe tener en cuenta dos condiciones. Estas dos condiciones podrían ser:

  • Que la función =SI hiciese algo sólo si se tuvieran que cumplir las dos

  • Que la función =SI hiciese algo si se cumpliese una de las dos

Controlaremos una u otra forma con dos operadores lógicos: el Y y el O

La sintaxis de la orden sería la siguiente

=SI(Y(Condición1:Condición2............   Caso en el que se deban cumplir todas las condiciones

=SI(O(Condición1:Condición2............    Caso que se deba cumplir sólo una

En el siguiente ejemplo hemos diseñado una hoja de control de flujo de caja en un hipotético caso en el que debamos controlar entradas y salidas además del saldo.
 

En las columnas C y D introduciremos las cantidades según sea un gasto (extracción) o un ingreso (depósito). Sería muy fácil colocar en la celda E5 (saldo) la siguiente fórmula: =E4+C5-D4, que calcularía el saldo anterior, más la cantidad de la celda del depósito, menos la cantidad de la celda de la extracción. El problema viene cuando copiamos la fórmula varias celdas hacia abajo. A partir de la celda del último saldo, siempre nos mostraría el saldo anterior, hubiésemos o no, introducido cantidades en las celdas de depósito o extracción.

Observa el resultado que se obtendría:

'Funciones'

Evidentemente, no queda muy estético a la vista. En la ilustración superior utilizamos la función =SI, la cual ha de controlar que se cumplan dos condiciones: que introduzcamos una cantidad en la celda del depósito o de la extracción. Sólo en uno de los dos casos se ejecutará la función. De esa forma, si todavía no hemos introducido nada en las celdas de la izuqierda, la función no se ejecutará. Observa a continuación las partes de la fórmula:

=SI(O    La letra O controla que se cumpla una de las dos condiciones

(C5>0:    Primera condición: que en C5 haya algo mayor de cero, es decir, un número positivo

D5>0)   Separada por dos puntos, la segunda condición controla lo mismo: que en D5 haya algún número.

;E4+C5-D5   caso de cumplirse una de las dos condiciones, se ejecutará esta fórmula.

;"")   caso de no cumplirse ninguna condición, no saldrá nada. Las dos comillas quieren decir caracter nulo.

Las funciones:
Promedio, Máxima, Mínima, Moda, Contar, Contar.si y Mediana

    Vamos a realizar un nuevo ejercicio que nos servirá para estudiar 5 nuevas funciones de Excel. Elaboraremos una supuesta tabla con los alumnos de una escuela. Los datos que tendremos son las notas de los tres trimestres. A partir de ahí, realizaremos una serie de cálculos utilizando las funciones que vamos a estudiar. Vamos primero a ver sus sintaxis, y a continuación su aplicación en el ejemplo:
 

=PROMEDIO(Número1;Número2;......)

Función que nos devolverá la media aritmética de los números o el rango encerrado entre paréntesis

Ejemplos:

=PROMEDIO(12;12;13) devolverá 12,33333

=PROMEDIO(A1:D13) devolverá el promedio del rango A1:D13

=MAX(Números)    =MIN(Números)

Estas funciones devuelven los valores máximo y mínimo respectivamente de una lista de números.

'Funciones'

=MODA(Números)

Valor que más se repite en un rango

'Funciones'

=CONTAR(Rango)

Cuenta las veces que aparece un elemento númerico en una lista.

=CONTARA(Rango)

Cuenta las veces que aparece un elemento de texto en una lista

'Funciones'

=CONTAR.SI(Rango)

Cuenta las celdas no vacías de un rango

'Funciones'

=MEDIANA(Números)

Número que se encuentra en medio de un conjunto de números, es decir, la mitad de los números es mayor que la mediana y la otra mitad es menor.

'Funciones'

   A continuación observa la siguiente tabla. Las celdas en color rosa contendrán las fórmulas.

'Funciones'

    Hemos de calcular los siguiente:

En la columna E la nota final que será la media de los tres trimestres.

En la columna F la evaluación en forma de texto. Haremos servir la función =SI para lo siguiente:

Si la nota media es de 0 a 4,99, aparecerá la palabra Insuficiente

Si la nota media es de 5 a 6,99, aparecerá la palabra Aprobado

Si la nota media es de 7 a 9,5, aparecerá la palabra Notable

Si la nota media es de 9,6 a 10, aparecerá la palabra Excelente

En las celdas inferiores calcularemos la Mediana, Notas máxima y mínima,  y moda

Finalmente, colocaremos unas celdas que nos informarán de:
   

El número de alumnos que hay

El número de insuficientes, aprobados, notables y excelentes que hay

Qué porcentaje representa cada uno de los anteriores

Solución a la hoja:
 
  'Funciones'

 
  Comentarios a las fórmulas:

Celda

FÓRMULA

ACCIÓN

E2

=PROMEDIO(B2:D2) (y copiar hacia abajo)

Halla la media de los números a su izquierda

F2

=SI(E2<4,99;"Insuficiente";SI(E2<6,99;"Aprobado";

SI(E2<9,5;"Notable";SI(E2<10;"Excelente"))))

Comprueba la nota para colocar un texto

B13, B14, B15,B16

=MAX(E2:E11)

=MIN(E2:E11)

=MOD(E2:E11)

=MEDIANA(E2:E11)

Halla la nota máxima, mínima, moda y mediana de la lista de notas finales

B19

=CONTAR.SI($F$2:$F$11;"Insuficiente")

Cuenta el número de insuficientes. Igual para las fórmulas de abajo

C19

=B19/$F$17

Halla el porcentaje

F17

=CONTARA(A2:A11)

Cuenta el número de alumnos de la lista de nombres