Diseño del algoritmo de una Eurocalculadora

Tabourier. Pseudocódigo. Algoritmos. Programación

  • Enviado por: Santiago García
  • Idioma: castellano
  • País: España España
  • 7 páginas

publicidad
cursos destacados
Aprende PHP+MySQL sin dolor
Aprende PHP+MySQL sin dolor
Con PHP se han hecho poderosos imperios, como Yahoo y Facebook. Comenzaremos desde lo básico, conociendo la...
Ver más información

Crea tu Tienda Online con PrestaShop
Crea tu Tienda Online con PrestaShop
Crea tu tienda Online con la versión más actual del líder en eCommerce, Prestashop 1.5.4.

La nueva función...
Ver más información


METODOLOGÍA DE LA PROGRAMACIÓN

PRÁCTICA DE LA EUROCALCULADORA

ÍNDICE

Programa Eurocalculadora.

Subprograma Carga.

Subprograma Menú.

Diagramas estructurados de Tabourier.

PROGRAMA EUROCALCULADORA

ENTORNO:

VALOR es tabla (11) numérica real.

OPC1, OPC2 son variables numéricas enteras.

MONEDA es tabla (11) alfanumérica.

CANT es una variable numérica entera.

OPC3 es una variable alfanumérica.

EUROS es una variable numérica real.

SW es una variable lógica.

ALGORITMO:

** Subprograma Carga.

ejecutar Carga ( VALOR, MONEDA ).

** Subprograma Menú.

ejecutar Menú ( OPC1 ).

** Algoritmo de Conversión de Monedas.

mientras OPC1 < > 3

sí OPC1 = 1

entonces SW CIERTO

sino SW FALSO

finsi

escribir “Seleccione el país deseado para la conversión”

escribir “ 1. España. “

escribir “ 2. Alemania. “

escribir “ 3. Holanda. “

escribir “ 4. Italia. “

escribir “ 5. Austria. “

escribir “ 6. Bélgica. “

escribir “ 7. Finlandia. “

escribir “ 8. Francia. “

escribir “ 9. Luxemburgo. ”

escribir “ 10. República Irlandesa. ”

escribir “ 11. Portugal. ”

escribir “ “

escribir “ Introducir Opción ”

leer OPC2

si SW = CIERTO

entonces

repetir

escribir “Introduzca cantidad en Euros”

leer EUROS

CANT VALOR (OPC2) * EUROS

escribir EUROS “Euros son”

escribir “ “

escribir “¿Desea convertir otra vez (S/N)?”

leer OPC3

hasta OPC3 = `N'

sino

repetir

escribir “Introduzca una cantidad”

escribir “de”, MONEDA (OPC2) “a convertir”

leer CANT

EUROS CANT/VALOR (OPC2)

escribir CANT, MONEDA (OPC2) “son”

escribir EUROS “Euros”

escribir “ “

escribir “¿Desea convertir otra vez (S/N)?”

leer OPC3

hasta OPC3 = `N'

finsi

ejecutar Menú (OPC1)

finmientras

FINPROGRAMA

SUBPROGRAMA Carga (VALOR, MONEDA).

Transforma VALOR, MONEDA.

ENTORNO:

VALOR es tabla (11) numérica real.

MONEDA es tabla (11) alfanumérica.

ALGORITMO:

**Introducción de los Datos en las Tablas.

**España.

VALOR(1) 166.386

MONEDA(1) “pesetas”

**Alemania.

VALOR(2) 1.95583

MONEDA(2) “marcos”

**Holanda.

VALOR(3) 2.20371

MONEDA(3) “florines”

**Italia.

VALOR(4) 1936.27

MONEDA(4) “liras”

**Austria.

VALOR(5) 13.7603

MONEDA(5) “chelines”

**Bélgica.

VALOR(6) 40.3399

MONEDA(6) “francos belgas”

**Finlandia.

VALOR(7) 5.94573

MONEDA(7) “markkas”

**Francia.

VALOR(8) 6.55957

MONEDA(8) “francos”

**Luxemburgo.

VALOR(9) 40.3399

MONEDA(9) “francos luxemburgueses”

**República Irlandesa.

VALOR(10) 0.787564

MONEDA(10) “libras irlandesas”

**Portugal.

VALOR(11) 200.482

MONEDA(11) “escudos”

FINSUBPROGRAMA

SUBPROGRAMA Menú(OPC1).

Transforma OPC1.

ENTORNO:

OPC1 es una variable numérica entera.

ALGORITMO:

**Entrada de Datos por Pantalla.

escribir “ EUROCALCULADORA”

escribir “ ------------------------------- “

escribir “ “

escribir “ “

escribir “ Menú Principal “

escribir “ --------------------------------“

escribir “ 1. Calculo de Euros a monedas”

escribir “ 2. Calculo de monedas a Euros”

escribir “ 3. Salir. “

escribir “ “

escribir “ Introducir Opción “

leer OPC1

FINSUBPROGRAMA

DIAGRAMAS ESTRUCTURADOS DE TABOURIER.

EUROCALCULADORA

BLOCK

CARGA

MENÚ

DO WHILE

BLOCK

OPC1<>3

IF THEN ELSE

MENÚ 1

IF THEN ELSE

CONECTOR

DO UNTIL

SW

MENÚ 2

OPC3='N'

SW FALSO

SW CIERTO

OPC1=1

CONECTOR

BLOCK

DO UNTIL

OPC3='N'

MENÚ 3